RTSystemEditor/RTCBuilder-1.0.0_en

eclipse_logo.png

All in one package (Eclipse-3.4.2 [Ganymede SR2])

Eclipse3.4.2+RTSE(1.0.0-RC1)+RTCB(1.0.0-RC1)
for Windows
eclipse342_rtmtools100rc1_win32_en.zip
MD5:5576048d910cc30fefabac8d499d14bf
2010.02.09
Eclipse3.4.2+RTSE(1.0.0-RC1)+RTCB(1.0.0-RC1) (Japanese)
for Windows
eclipse342_rtmtools100rc1_win32_ja.zip
MD5:2d591e2cf5b4c6d12b44c5eca4e3847e
2010.02.09
Eclipse3.4.2+RTSE(1.0.0-RC1)+RTCB(1.0.0-RC1)
for Linux
eclipse342_rtmtools100rc1_linux_en.tar.gz
MD5:85d5f5a875675fecfd4e2c90aa02dd4e
2010.02.09
Eclipse3.4.2+RTSE(1.0.0-RC1)+RTCB(1.0.0-RC1) (Japanese)
for Linux
eclipse342_rtmtools100rc1_linux_ja.tar.gz
MD5:8d5e7213d261bff95df80e70298c6bc1
2010.02.09
Eclipse3.4.2+RTSE(1.0.0-RC1)+RTCB(1.0.0-RC1)
for Mac OS Xnew!
eclipse342_rtmtools100rc1_macosx_en.tar.gz
MD5:91f004ac1e3a760a2a16db32d02cb8ac
2010.02.24
Eclipse3.4.2+RTSE(1.0.0-RC1)+RTCB(1.0.0-RC1) (Japanese)
for Mac OS Xnew!
eclipse342_rtmtools100rc1_macosx_ja.tar.gz
MD5:6177f834a51cf40c628060255f587666
2010.02.24



  • Eclipse 3.4.2 does not work on Ubuntu8.04 and Ubuntu9.10.
    • For Ubuntu8.04: apt-get install xulrunner-1.9 to update xulrunniner
    • For Ubuntu9.10: Please try the following method or use Eclipse3.3 or 3.5.
       $ su
       # vi /etc/apt/source.list
        add this line → deb http://jp.archive.ubuntu.com/ubuntu/ jaunty main restricted
       # apt-get update
       # apt-get install xulrunner-1.9
       # dpkg -l |grep xulrunner-1.9
       ii  xulrunner-1.9                        1.9.0.8+nobinonly-0ubuntu2                 XUL +  XPCOM application runner
       ii  xulrunner-1.9.1                      1.9.1.7+nobinonly-0ubuntu0.9.10.1          XUL + XPCOM application runner
       ii  xulrunner-1.9.1-gnome-support        1.9.1.7+nobinonly-0ubuntu0.9.10.1          Support for GNOME in xulrunner-1.9.1 applica
       1.9.1 and 1.9 coexist
       # exit
       $ export GDK_NATIVE_WINDOWS=1
       $ ./eclipse
      or, xulrunner-1.9.1.8 can be used for eclipse 3.4.x. Please update with xulrunner 1.9.1.8, and create the following shell script to launch eclipse.
       #/bin/sh
       export GDK_NATIVE_WINDOWS=1
       ./eclipse -vmargs -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-1.9.1.8/xulrunner

RTSsytemEditor/RTCBuilder daily build

RTSystemEditor and RTCBuilder are frequently updated. The daily build for RTSE/RTCB in the following URL.
  • The newest version of RTSsytemEditor/RTCBuilder are available.
  • This is development version. So we cannot guarantee these tools works well.
  • PLease copy jar files included archived files into plugin directory of eclipse.
  • It is better to launch eclipse with "-clean" option.
  • Download URL: http://www.openrtm.org/pub/OpenRTM-aist/dailybuild/tools/1.0.0/
    • Setting up downloading Eclipse SDK package and adding plugins by your self, EMF SDO runtime, GEF, XSD runtime plugins are neccesarry to use RTSE/RTCB.



Eclipse/JDK/JRE etc

JDK/JRE

Eclipse Download




latest Releases

For Begginers

Windows msi(installer) package (only trying samples)

Development environment is required for RT-Component development. See download page for details.

Number of Projects

OpenHRP3

Dynamics simulator

OpenHRI

Human-Robot-Interaction RTCs

OpenRTP

Integrated Development Platform

OpenINVENT

Mobile Robot RTCs