OpenRTM-aist-Python-1.0.0-RC1_en

python-logo.png

Source Code/Patch

Source code (Python) OpenRTM-aist-Python-1.0.0-RC1.tar.gz 09/08/13
Source code (Python2.4+Win32) OpenRTM-aist-Python24-1.0.0-RC1.zip 09/08/13
Source code (Python2.5+Win32) OpenRTM-aist-Python25-1.0.0-RC1.zip 09/08/13
Patch OpenRTM-aist-Python-1.0.0-RC1 patch-OpenRTM-aist-Python-1.0.0-RC1-20090818 09/08/18

The version that applied patch was released as RC1-p1 because there was a serious bug in 1.0-RC1.
If you have already downloaded 1.0- RC1, we recommends the replacement with 1.0-RC1-p1.

Pre-built Package (Windows)

Python2.4

Installer for Windows
(for only for Python2.4)
OpenRTM-aist-Python24-1.0.0-RC1.msi 09/08/13
Python-2.4.4 installer python-2.4.4.msi python.org
omniORBpy-2.7 installer
(offered by AIST)
omniORBpy-2.7.msi 2007.11.09
omniORBpy-2.7 (Pre-built Binary Archive) omniORBpy-2.7-win32-python2.4.zip sourceforge

Python2.5

Installer for Windows
(for only for Python2.4)
OpenRTM-aist-Python25-1.0.0-RC1.msi 09/08/13
Python-2.5.1 installer python-2.5.1.msi python.org
omniORBpy-3.1 installer
(offered by AIST)
omniORBpy-3.1.msi 2007.11.09
omniORBpy-3.1 (Pre-built Binary Archive) omniORBpy-3.1-x86-win32-python2.5.zip sourceforge

Python2.6

Installer for Windows
(for only for Python2.6)
OpenRTM-aist-Python26-1.0.0-RC1-p1.msi 09/09/02
Python-2.6.2 python-2.6.2.msi python.org
omniORBpy-3.4 installer
(offered by AIST)
omniORBpy-3.4.msi 2009.08.31
omniORBpy-3.4 (Pre-built Binary Archive) omniORBpy-3.4-x86_win32-python2.6.zip sourceforge

Pre-built package (UNIX)

You can install rpm/deb packages with apt-get and yum from OpenRTM-aist's repository. Refer to Documents for C++.

Release note: 1.0.0-RC1

  • OpenRTM-aist-Python-1.0.0-RC1.tar.gz -- 09/08/13
    • Officially based on OMG RTC Specification 1.0
    • Support new data port 1.0
    • Miscellaneous bug fixes
    • Requirement
      • omniORBpy
         Supported Version: 2.3, 2.7, 3.2
      • Tkinter
         need for GUI Component
    • Supported Python (Verified)
      • 2.4
      • 2.5
    • Supported OS (Verified)
      • Debian4.0-i386
      • Debian5.0-i386
      • Fedora release 10 (Cambridge)-i386
      • Fedora release 11 (Leonidas)-i386
      • Ubuntu 8.04-i386
      • Ubuntu 8.10-i386
      • Ubuntu 9.04-i386
      • Vine Linux 4.0 (Latour)-i386
      • Vine Linux 4.1 (Cos d'Estournel)-i386
      • Vine Linux 4.2 (Lynch Bages)-i386
      • Windows XP
      • Windows Vista

Previous

latest Releases

For Begginers

Windows msi(installer) package (only trying samples)

Development environment is required for RT-Component development. See download page for details.

Number of Projects

OpenHRP3

Dynamics simulator

OpenHRI

Human-Robot-Interaction RTCs

OpenRTP

Integrated Development Platform

OpenINVENT

Mobile Robot RTCs